View8400 Software
User’s Manual

Monitoring and configuration software
for the OmniSTAR 8400HP receiver

Issue 2, June 2005
Notice to Customers

This manual has been produced to provide instructions how to use View8400 version 1.2.2 software with your OmniSTAR 8400HP receiver. The manual has been clearly set out with simple instructions to ensure trouble free usage of the software.

This publication could contain technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the manual.

REVISION HISTORY

<table>
<thead>
<tr>
<th>Issue</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>August 2004</td>
<td>First Issue</td>
</tr>
<tr>
<td>1.1</td>
<td>January 2005</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>June 2005</td>
<td>View8400 version 1.2.2</td>
</tr>
</tbody>
</table>


© Copyright OmniSTAR B.V. 2005. No part of this manual can be reproduced without the express permission of OmniSTAR B.V.
OmniSTAR View8400 Software User’s Manual

TABLE OF CONTENTS

INTRODUCTION ................................................................................................ 5

ABOUT THIS MANUAL ....................................................................................... 5
REQUIREMENTS ............................................................................................... 5

INSTALLATION ................................................................................................. 5

STARTING THE VIEW8400 SOFTWARE ............................................................ 5

CONNECT THE 8400HP TO THE COMPUTER ....................................................... 5
START UP THE VIEW8400 SOFTWARE ............................................................ 5
CONNECT VIEW8400 TO THE 8400HP ............................................................ 6

CHECKING THE STATUS OF THE 8400HP .................................................... 8

POSITION WINDOW ........................................................................................... 8
DGPS CORRECTION SATELLITE STATUS WINDOW .............................................. 9
SUBSCRIPTION DETAILS WINDOW ................................................................ 10
FIRMWARE VERSION WINDOW ......................................................................... 11
GPS SATELLITES WINDOW ............................................................................. 12
SKYPLOT WINDOW .......................................................................................... 13
SCATTERPLOT WINDOW .................................................................................. 14

CONFIGURE THE 8400HP ............................................................................. 15

CONFIGURE THE OmniSTAR SATELLITE SERVICE ............................................ 15
CONFIGURE THE RECEIVER PORTS ................................................................. 16
GPS board ................................................................................................ 16
HP board .................................................................................................... 16
CONFIGURE THE GPS RECEIVER SETTINGS ..................................................... 17
Configure the HP receiver settings........................................................... 18
CONFIGURE NMEA OUTPUT ........................................................................... 20
GPS port ................................................................................................... 20
HP port ...................................................................................................... 21
TERMINAL MODE ............................................................................................. 22

LIST OF FIGURES

Figure 1 Main screen after start up .................................................................... 6
Figure 2 Select Com Port window ...................................................................... 7
Figure 3 Main screen after connection............................................................... 7
Figure 4 Position window ................................................................................... 8
Figure 5 DGPS correction satellite status window ............................................. 9
Figure 6 Subscription details window............................................................... 10
Figure 7 Firmware version window .................................................................. 11
Figure 8 GPS Satellites window....................................................................... 12
Figure 9 GPS Satellites window....................................................................... 13
Figure 10 GPS Satellites window..................................................................... 14
Figure 11 Select DGPS Service window.......................................................... 15
Introduction

About This Manual
This manual has been produced to allow the typical user to easily control the OmniSTAR 8400HP from your PC.

Requirements
A windows 9X/ME/NT/2000/XP based PC with one RS232 COMM. Port is needed for the View8400 software.

Installation
Double click on the View8400 setup.exe file.
Follow the on screen instructions to install the View8400 software.

Starting the View8400 software

Connect the 8400HP to the computer
Before using the software the HP port of the 8400HP must be connected to the serial port of the PC via the serial cable that was provided with the 8400HP.
The View8400 software only works properly when connected to the HP port of the 8400HP.
Version 1.2.2 of the View8400 software can optional connect to the 8400HP with two serial ports, one for the HP port and one for the GPS port.

Start up the View8400 software
Click on the Windows Start button and select Programs -> OmniSTAR -> View8400 and click on View8400.
If you’ve chosen a different location for the software during the installation than go to that location to start up View8400.
Once the program has started you'll see the following screen.

![Main screen after start up](image)

**Figure 1 Main screen after start up**

### Connect View8400 to the 8400HP

From the main screen menu (see figure 1) click File -> Connect. The Select Com Port window will pop-up (see figure 2). Select the serial port of the PC the 8400HP is attached to and configure the port using the Configure button. If you have two serial cables it is possible to use the ‘Use two com ports’ option.

The most common setting for the communication is 115200 baud, 8 data bits, ‘N’ parity and 1 stop bit for both the HP and the GPS port (port A).

After clicking OK from the Select Com Port window the program returns to the main screen and the labels should be filled with information from the receiver (see figure 3).

If you check “Auto connect at next start up” View8400 will automatically connect on the next start up using the last used Com settings.
Figure 2 Select Com Port window

Figure 3 Main screen after connection
Checking the status of the 8400HP

Position window

The position window (see figure 4) provides the current position of the antenna connected to the receiver. It also provides the date and time, velocity, standard deviation values, PDOP value, Age of Data of the OmniSTAR correction signal, number of L1 and L2 observations and the positioning mode. By clicking the tabs you can view the position in different formats.

![Figure 4 Position window](image)

Figure 4 Position window
DGPS correction satellite status window

The DGPS correction satellite window (see figure 5) provides detailed information about the status of the connection with the OmniSTAR satellite.

![Figure 5 DGPS correction satellite status window](image)

Figure 5 DGPS correction satellite status window
Subscription details window

The subscription details window (see figure 6) provides the OmniSTAR VBS and OmniSTAR HP subscription information.

Figure 6 Subscription details window
Firmware version window

The firmware version window (see figure 7) provides the receiver model, serial number, RAM size and firmware versions.

![Firmware version window](image)

Figure 7 Firmware version window
GPS Satellites window

The GPS Satellites window (see figure 8) provides the PRN number, elevation, azimuth, C/A carrier to noise ratios, P/L1 carrier to noise ratios, P/L2 carrier to noise ratios, time since last loss-of-lock and satellite navigation status of the GPS satellites in view.

![GPS Satellites window](image)

Figure 8 GPS Satellites window
Skyplot window

Click in the menu on View -> Skyplot to view the Skyplot window. The Skyplot window (see figure 9) provides a skyplot of the GPS satellites in view and the OmniSTAR satellite. By clicking on the satellite icons the PRN, elevation, azimuth, C/A snr, P/L1 snr, P/L2 snr, and Nav. Status of the particular satellites will be shown.

Figure 9 GPS Satellites window
Scatterplot window

Click in the menu on View -> Scatterplot to view the Scatterplot window (see figure 10).

Figure 10 GPS Satellites window
Configure the 8400HP

Configure the OmniSTAR satellite service

From the main screen menu click Configuration -> DGPS service. The Select DGPS service window (see figure 11) will pop-up.

Select OmniSTAR as differential source and choose the right satellite for your region. To fill in a frequency and symbol rate manually choose Custom as the satellite.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them.

Figure 11 Select DGPS Service window
Configure the receiver ports

GPS board

From the main screen menu click Ports -> GPS -> Port A or Internal. If you have only one serial cable and do not use the 'use two com ports' option. A message box will pop-up saying to switch to receiver port A. This is because the port settings for the GPS board can only be changed through port A.

Switch to receiver port A and click OK. The Port settings window (see figure 12) will pop-up.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them. After this a message box will pop-up again saying to switch back to the HP port.

HP board

From the main screen menu click Ports -> HP -> External or Internal.

The Port settings window (see figure 12) will pop-up.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them.

Figure 12 Port settings window

Note: The internal port of the GPS board communicates with the internal port of the HP board. These port settings should always be the same.
Configure the GPS receiver settings

From the main screen menu click Configuration -> GPS receiver settings. A message box will pop-up saying to switch to receiver port A. This is because these settings can only be changed through port A.

Switch to receiver port A and click OK. The GPS receiver settings window (see figure 13) will pop-up.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them. After this a message box will pop-up again saying to switch back to receiver port C.

Figure 13 GPS receiver settings window
Configure the HP receiver settings

From the main screen menu click Configuration -> HP receiver settings.

The HP parameters window will appear (See figure 14).

![HP Parameters](image)

Figure 14 HP parameters window

In the 8400HP manual an explanation of the different parameters is given.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them.
GPS receiver options

From the GPS receiver settings window click “GPS receiver options”. View8400 will query the receiver and show the installed options in the GPS receiver options list (see figure 15).

![GPS receiver options window](image)

Figure 15 GPS receiver settings window
Configure NMEA output

GPS port

From the main screen menu click Configuration -> NMEA output -> Port A. A message box will pop-up saying to switch to receiver port A. This is because these settings can only be changed through port A.

The Port A output window (see figure 16) will pop-up.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them.

![Port A output window](image)

Figure 16 Port output window
HP port

From the main screen menu click Configuration -> NMEA output -> HP port.

The HP Port output window (see figure 17) will pop-up.

At the moment of writing this manual it is only possible to output GGA, GSA and HP Debug data from the HP port.

Clicking OK will send the changes to the receiver. Clicking Cancel will discard them.

![HP Port output window](image)

Figure 17 Port output window
Terminal mode

View8400 has a terminal mode, which can be used to send commands and text files to the receiver.

From the main screen menu click Configuration -> Terminal mode.

The terminal window (see figure 18) will pop-up.

The send button sends the command in the command combobox to the receiver HP port or the GPS port. If you do not use the ‘Use two com ports’ option the commands can only be send to the HP port. With the Send text file button you can select a text file with several commands to send to the receiver. The close button closes the terminal window and returns to the main screen. The exit button terminates the whole program without returning to the main screen.

![Terminal window](image)

Figure 18 Terminal window